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Installation tiamo 2.x

1 Minimum system requirements
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Operating system

RAM

Hard disk space

Serial ports
USB ports
Screen

Network

The Windows user must have administrator rights in order to be able to install

the tiamo software.

32-bit version of:

= Windows 8 Professional/Enterprise

= Windows 7 Professional/Ultimate/Enterprise
= Windows Vista Business/Enterprise/Ultimate
= Windows XP Professional SP2

= Windows Server 2008 R2

= Windows Server 2008

= Windows Server 2003

64-bit version of;

= Windows 8 Professional/Enterprise

= Windows 7 Professional/Ultimate/Enterprise
= Windows Server 2012

= Windows Server 2008 R2

Windows Vista and higher: 2 GB
Windows XP: 1 GB

Program: 1 GB

Data: 2 GB

For devices with RS-232 interface
For devices with USB interface
Resolution: 1,024 x 768

10 Mbit/s, stable and permanent

Communication via TCP/IP

@ CAUTION

Data loss may occur if the PC changes to sleep mode during a determina-

tion. The sleep mode should therefore be deactivated in the energy set-

tings of the operating system.



2 Single workplace installation

With the single workplace version tiamo light or tiamo full, you can install
both the tiamo client and the server on the computer.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.

3 After having read the license agreement for tiamo and accepted it with
[Yes], a window will appear where you can enter the license code.

Metrohm Tiamo 2.0 Setup x|
License code
Flease type inyour license code. n Meﬂ‘ohm

License code |TI20

InstallShield

< Back | Iext > I Cancel |

4 Enter the license code for tiamo light or tiamo full and then click on
[Next >].

E NOTE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.
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Metrohm Tiamo 2.0 Setup x|

License code

Please type in your license code. n MetrOhm

License code |TIZD -l alb2 -] c3d4 -l 4711 -] ab12 -] ff11

@ The licence code is valid only for & program update.
Flease enter the licence code of the previous full wersion.

License code |

InstallShield

< Back | ext » I Cancel |

5 Now confirm the target folder for the tiamo installation with [Next >] or
select a different target folder with [Browse...].

6 You can define the paths for the database and default backup files in the
Additional installation information window:

Metrohm Tiamo 2.0 Setup x|

Additional installation information.
Flease enter the necessary infarmation n Meh‘ohm

for the operation.

@ Every user needs readfwrite rights far the specified directaries!

Database path |C:\Programme\Metrohm\tiamo\Data |
Default backup path |C:\PrDgramme\Metrohm\tiamo\Backup |
Advanced... |

InstallShield

Cancel |

< Back

E NOTE

The default paths are different for Windows XP, Windows Vista, Win-
dows 7 and Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.

You can change the ports tiamo uses to communicate with the database
server and the administration server with the [Advanced...] button. If
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the ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].

Follow the instructions of the program until the following message
appears:

Metrohm Tiamo 2.0 Setup il

i If you use a firewal program please check its settings.
tiamo uses the following ports:
6001, 6002, 5645, 5646

This message points out again which ports tiamo uses. Write down these
ports and inform your system administrator in case tiamo is not able to
connect to the database. Confirm the message with [OK].

tiamo will now be installed.

Once the copying procedure has been completed you can make further
workplace settings:

Metrohm Tiamo 2.0 Setup x|
Workplace settings
Please setyour client 1D and your n Meh‘ohm

preferred language.

Client ID |PKL—NEI

[ This client I must existin the current tiamo
Sy/ETErm.

Language IEninsh LI

InstallShield

< Back | ext » I Cancel |

The option This client ID must exist in the current tiamo system.
can only be activated if a database from a previous installation already
exists on your computer or if you want to connect to a database server
which is installed on another computer (the latter case only applies to
tiamo multi).

If you enable this option, then tiamo checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
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case, check your server and firewall settings before installing the program
again.

9 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current tiamo installa-
tion. Save this file on your hard drive for future reference and print it (add
1o 1Q).

ﬂ NOTE

An InstallLog file can be found in the installation directory of tiamo
under ...bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

10 Complete the installation with [Finish].

3 Client/server installation

8.101.8056EN

With the tiamo multi version (multi-client version with three licenses) you can
select during the installation whether you want to install only a Client or a
client and a server (database server) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 Follow steps 1 to 5 of the single workplace installation (see Chapter 2,
page 2).

2 The Additional installation information dialog appears. Here you can
select whether you want to install only a Client or a client and a server
(database server) on your computer.



il

Additional installation information.

Flease enter the necessary infarmation n Meﬂ‘ohm

for the operation.

@ Client/Server

€3] Ewery user needs read fwrite rights far the specified directaries!

Database path |C:\Programme\Metrohm\tiamo\Data _l
Default backup path |C:\Programme\Metrohm\tiamo\Backup _l
(" Client
Sen/er _l
Advanced... |
InstallZhield
< Back Cancel |

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

E NOTE

The default paths are different for Windows XP, Windows Vista, Win-
dows 7 and Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.
With Client, only the client will be installed, and you have to select the
database server (has to be installed in advance!) you would like to use

with the |;| button. The network server name or the IP address is
accepted as the name.

You can change the ports which tiamo uses to communicate with the
database and administration server under [Advanced...]. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].

3 All further installation steps correspond to those of the single workplace
installation from point 7 onwards (see Chapter 2, page 2).

Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current tiamo installation, start the
setup.exe file on the installation CD or click under:

= Windows XP - Control Panel » Software
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=  Windows Vista / Windows 7 / Windows 8 - Control Panel » Programs
and Features

on Metrohm tiamo. Then select Change/Remove:

Metrohm Tiamo 2.0 Setup x|
Welcome
todify. repair, update, or remove the program. n Meﬂ‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

Select new program features to add or select currently installed features to
FEMTIOVE.

 Repair/Update
ﬁ Feinstall all program features installed by the previous setup.

(" License upgrade
= MNew license
i

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel

Modify

With this option you can adjust the paths to the database and backup files and
change the ports which tiamo uses for communication. With the tiamo multi
version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.

= Repairing the installation
In case of a defective tiamo installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, tiamo can be
repaired with this option.

= Updating the installation
In case an older version of tiamo is installed, it will be updated to the new
version of tiamo, see Program update with tiamo light/full or Program
update with tiamo multi.

@ CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new versions; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

8.101.8056EN



License upgrade

Remove

A direct upgrade of your current installation to a tiamo version with additional
features is possible with this option:

= tiamo light to tiamo full or tiamo multi
= tiamo full to tiamo multi

In order to do this, enter your new license code in the next dialog window.

This option removes your tiamo installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

5 Program update with tiamo light/full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use with the new version.

ﬂ NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new versions; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

1 Save the configuration database into an external directory using the
backup function of tiamo. In the Configuration program part, select the
File » Backup » Manually menu item. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is cre-
ated. It is recommended to copy the backup file to CD/DVD afterwards.
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2

If desired, export the methods in addition to the backup with the configu-
ration database (see above) into an external directory. In the Method
program part, select the File » Method manager... menu item. Select
the desired Method group, select all methods to be exported and click
on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. Afterwards,
copy the method files to CD/DVD.

Save all determination databases created by you into an external directory
using the backup function of tiamo. In the Database program part,
select the File » Database manager... menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is created.
Afterwards, copy the backup file to CD/DVD.

Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

Close tiamo. Insert the installation CD and double-click on the setup.exe
file. Then select Repair/Update and click on [Next >].

Metrohm Tiamo 2.0 Setup x|
Welcome
todify. repair, update, or remove the program. n Meﬂ‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

 todify
ﬁ Select new program features to add or select currently installed features to
FEMTIOVE.

=
einstall all program features installed by the previous setup.

(" License upgrade
= MNew license
i

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel |

6 \When updating older tiamo versions (1.x) to tiamo 2.x, you have to enter

your update license code and then click on [Next >].
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il

License code

Please type in your license code. n Meﬂ'ohm

License code |TI20

InstallShield

< Back | ext > I Cancel

7 Complete the installation with [Finish].

E NOTE

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation for a
successful installation is saved in the tiamo installation folder under
...bin\InstallLog.

6 Program update with tiamo multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the sever are automatically updated for further use with the new
version of tiamo multi.

H NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.
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CAUTION

When older tiamo versions (1.x) are updated to tiamo 2.x, the databases will
be converted to the new versions; depending on the size of the database,
this may take some time. For each database a progress bar which informs
about the status of the conversion is displayed.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

1 Make sure tiamo multi is closed on all clients.

E NOTE

In the bin subdirectory of the tiamo installation, you can find the Cli-
ents.exe application, with which all clients and their status can be dis-
played.

2 Open tiamo multi on the server and save the configuration database
into an external directory using the backup function of tiamo. In the
Configuration program part, select the File » Save » Manually menu
item. Select the Backup directory, enter a name for the backup file and
click on [Start]. The backup is created. Afterwards, copy the backup file
to CD/DVD.

3 If desired, export the methods in addition to the backup with the configu-
ration database (see above) into an external directory. In the Method
program part, select the File » Method manager... menu item. Select
the desired Method group, select all methods to be exported and click
on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. Afterwards,
copy the method files to CD/DVD.

4 Save all determination databases that are present on the server into an
external directory using the backup function of tiamo. In the Database
program part, select the File » Database manager... menu item. Select
the desired database and click on [Backup]. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
created. Afterwards, copy the backup file to CD/DVD.

5 Save further files in the installation directory (e.g. export files) into an
external directory or to CD/DVD.

6 Updating the server

Close tiamo multi on the server and on all clients. Insert the installation
CD on the server and double-click on the setup.exe file. Then select
Repair/Update and click on [Next >].

11



Metrohm Tiamo 2.0 Setup il

Welcome

todify. repair, update, or remove the program. n Meh‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.
" Modify

@ Select new program features to add or select currently installed features to
FEMTIOVE.

ﬁ Feinstall all program features installed by the previous setup.

(" License upgrade
= MNew license
Jia

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel |

7 \When updating older tiamo versions (1.x) to tiamo 2.x, you have to enter
your update license code and then click on [Next >].

Metrohm Tiamo 2.0 Setup il
License code
Please type in your license code. n Meh‘ohm

License code |TI20 - - - - -

InstallShield

< Back | ext > I Cancel

E NOTE

The update of tiamo multi consists of the server license and three cli-
ent licenses. If an existing installation contains additional client licenses,
these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

9 Complete the installation with [Finish].
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E NOTE

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a suc-
cessful installation is saved in the installation folder of tiamo under
bin\InstallLog.

10 In case additional licenses have been removed during the server update or
if further licenses are to be added, the Administrator can enter them in
tiamo (dialog: Configuration » Tools » Program administra-
tion » Licenses » Add licenses).

11 Updating clients

For each client, insert the installation CD and double-click the setup.exe
file. Then select Repair/Update and click on [Next >]. Complete the
installation with [Finish].

H ™

In order to facilitate the updating of many clients, the installation can
be copied from the CD to a writeable medium and the file
tiamo_init.ini can be modified. There, user-defined parameters for the
installation (license code, installation path, server name, etc.) can be set
in advance, which allows you to only have to click through the installa-
tion.

n NOTE

An UpdateLog file with a list of all files that have been copied to the
client computer during the program update and with a confirmation
for a successful installation is saved in the client's tiamo installation
folder under bin\InstallLog.

7 Installation of drivers
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In normal cases, the installation routine of tiamo automatically installs all the
drivers necessary for controlling the supported devices.

If you are using a 64-bit operating system, it may be necessary to install drivers
manually in combination with a few devices. This is the case if the operating
system displays a message when connecting a device to the computer, e.g.
Device driver software was not installed. No driver found. The mes-
sage should also show the name of the corresponding device. Write down this
name and proceed as follows to install the driver manually:
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H NOTE

The following description applies for Windows 7 (64-bit version). It may
slightly vary for your system.

1 Open the Windows Device Manager. The corresponding device can be
found under Other devices.

2 Right-click on the device. The context menu opens.

3 In the context menu, select Update Driver Software.... A dialog win-
dow opens.

4 Select Browse my computer for driver software. The file selection
dialog opens.

5 Navigate to the installation folder of tiamo (default: C\Program Files
(x86)\Metrohm\tiamo).

6 In the installation folder, open the drivers subfolder. This folder contains
the Avantes subfolder, in which you can find the driver for the Avantes
spectrometer.

7 In the drivers subfolder, open the subfolder of the corresponding device
and select the driver file (*.inf).

8 Apply the selection with [OK]. A Windows safety prompt is displayed. In
order to install the driver, click on [Install].

9 After successful installation, close the Device Manager.

8 Adding additional licenses with Windows Vista
or newer

General

Since Windows Vista, Microsoft has introduced the UAC (User Account Con-
trol), which permits running tasks either as non-administrator or as administra-
tor (without changes of user, switching off or similar).

http.//technet.microsoft.com/en-us/library/cc709691%28WS. 10%29.aspx
http.//technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client-server installations of
tiamo.

8.101.8056EN


http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx
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Problem description

One would like to add additional licenses for the program; the license code for
an additional 5 licenses, for example, is added (on the server) in the program
part Configuration in the dialog window Program administration (accessi-
ble via menu item Tools » Program administration..., tab Licenses).

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\tiamo\bin).

If one adds the 5 licenses and then looks at this file license.mlic, only the
standard license code will be listed (for 3 licenses).

If one highlights the file license.mlic and presses Compatibility files in the
bar, then one will arrive in the directory C:\Users\'User‘\AppData\Local\Vir-
tualStore\Program Files\Metrohm\tiamo\bin (‘User’' being the abbrevia-
tion (UID) for the user logged in on the operating system). The file
license.mlic with the license codes for the standard licenses and the 5 newly
added licenses is to be found here, i.e. the additional licenses are stored in the
VirtualStore only for the Windows user who was logged in on the PC at the
time the additional licenses were added.

On the server, the program recognizes all of the licenses; the operating system
adds the file license.mlic from the directory C:\Users\'User"\AppData\Local
\VirtualStore\Program Files\tiamo\bin to the detail list of the directory C:
\Program Files\Metrohm\tiamo\bin.

For the client-server functionality of the database server, however, the file
license.mlic in the directory C:\Program Files\Metrohm\tiamo\bin is rele-
vant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings).

Remedy

= For new installations
— To enter additional licenses, the program must be started as adminis-
trator (position the mouse on the Program icon and click the right
mouse button — select Run as administrator there).
— If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\tiamo\bin will contain both license codes.
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= For existing installations

— First of all, the file license.mlic in the directory C:\Users
\'User"\AppData\Local\VirtualStore\Program Files\Metrohm

\tiamo\bin must be deleted.

This file must not be present in the VirtualStore of any user —a
check must be made to make sure of this, and any such files which
may be found must be deleted.
— Afterwards, the program must be started as administrator (position
the mouse on the Program icon and click the right mouse button —
select Run as administrator).
If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\tiamo\bin will contain both license codes.

9 User rights for tiamo

In order for the logged-in user to be able to access all functions with tiamo,
the Windows system administrator must ensure that the permissions are set for

the directories as listed below:

Directory Permission Group name or
user name

Database directory Modify SYSTEM

Directory where the databases will be saved (...\Data). User”

Backup directory Modify User”

Directory where the backup copies will be stored

(...\Backup).

%ALLUSERSPROFILE%\Application Data\Metrohm Modify User”

(Windows XP)™

%PROGRAMDATA%\Metrohm (Windows Vista and Modify User”

higher) **

Export directories Modify User

Directories where the exported files are to be saved.

PDF directories Modify User

Directories where the PDF files are to be saved.

Desktop Modify User

%PROGRAMFILES%\Metrohm\tiamo Read Execute User

User = name of the user who is logged in

During installation of tiamo the permission Full Control is set for the following groups: SYS-

TEM, Administrators, Users, Guests, Main users.
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